It is currently Sun Jul 05, 2020 11:08 am

All times are UTC - 8 hours




 Page 1 of 4 [ 90 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: 2 cyclones in a honda civic hatch in the uk
PostPosted: Wed Mar 25, 2009 1:27 pm 

Joined: Sun Apr 15, 2007 2:11 pm
Posts: 64
Well after some hard slog we managed to find 4 cuft and some boot space and create this install.

standard h/u runing through jl clean sweep into
eclipse 8445
dynaudio system 360
3 x jl hd750/1's
2 x cyclones

Your thoughts are always welcome but yes 2 cyclones working nice in a car!


Attachments:
100_1147 edited.JPG
100_1147 edited.JPG [ 212.1 KiB | Viewed 11127 times ]
100_1148 edited.JPG
100_1148 edited.JPG [ 210.48 KiB | Viewed 11127 times ]
Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 1:29 pm 
Randy Bo-Bandy
User avatar

Joined: Fri Feb 06, 2009 11:32 pm
Posts: 3301
Very, very nice....looks stock


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 1:35 pm 
SOFA-KING
User avatar

Joined: Sat Nov 29, 2008 11:54 am
Posts: 5348
Location: Graz, Austria
I can´t wait! :D :D :D Awesome install :shock: :shock: :shock:



_________________
Music is silver, PHOENIX is GOLD
Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 2:02 pm 
Voltage Ohms
User avatar

Joined: Sat Nov 26, 1983 4:00 am
Posts: 14699
Location: Burnaby, BC
How do you find the Clones inverse mounted like that? I would think there would be more motor noise. Other than that, the design seems like it would work either way.

Very spiffy install otherwise! Amazing that you managed to shoehorn TWO of those beasts in a little euro Civic hatch.


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 2:48 pm 

Joined: Sat Jan 20, 2007 12:15 pm
Posts: 756
Location: Souf africa
I love that install man. top notch .



_________________
AKA Shaheenk
Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 2:53 pm 
User avatar

Joined: Wed Aug 22, 2007 7:39 pm
Posts: 551
Location: The land of OZ
Nice install.

How's the sound of the Cyclone's in a hatch?? Can you hear any motor noise from them?



_________________
M25 x 2, M50, M44, M100, Original MS 275, MS2125 & MS2250 (with shroud), XMax 15, White EQ215X, EQ232, PLD1,BLT, MX3, AX-406A, Basscubes, + Soundstream, Earthquake, RF, Boston, OZ Audio & KEF
Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 3:24 pm 
User avatar

Joined: Fri Jan 12, 2007 2:41 pm
Posts: 205
Location: Portland, OR.
[quote="stipud"]How do you find the Clones inverse mounted like that? I would think there would be more motor noise. Other than that, the design seems like it would work either way.

Very spiffy install otherwise! Amazing that you managed to shoehorn TWO of those beasts in a little euro Civic hatch.[/quote


PG had 4inverted cyclones on the dually back in the day. No motor noise due to the bass.... Of course if you sit close enough and listen for the motor then you'll hear the motor noise.

Bangin install!!!!! Nice!



_________________
Enjoying great sight and sound does not have to consume your life savings!

www.dc-connections.com
Offline
 Profile  
 
 Post subject: cyclones
PostPosted: Wed Mar 25, 2009 4:18 pm 

Joined: Sun Apr 15, 2007 2:11 pm
Posts: 64
thanks for your responses. As for motor noise I cleaned one out about a year ago. No motor noise. They sound clean and good. I remember the dually. I heard it on a trip over iasca finals 96. They were running off of 2 0.5's. It was the lowest and cleanest low bass I have heard. Always inspired me hence I sourced 2 and he they are....


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Mar 25, 2009 9:54 pm 
Mr. Nice Guy
User avatar

Joined: Wed Dec 13, 2006 4:39 pm
Posts: 5750
Gratest1 wow...excellent install. I might have to work something out with my 2 clones....wow is all I gotta say...wow....


Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 5:59 am 
Dirty Harry
User avatar

Joined: Sat Jan 26, 2008 11:53 pm
Posts: 5678
Location: Oregon Grown
Sweet!!!! Sleeping thunder machine..... :lol:



_________________
Those tender little burgers with them little, itty-bitty grilled onions that just explode in ya mouth like flavor crystals every time you bite into one.. just makes me want to burn this muthafuka down.... Come on, Pookie, let's burn this muthafuka down!!!
Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 10:40 am 
User avatar

Joined: Sun Feb 11, 2007 11:41 am
Posts: 831
Location: Fossambault-sur-le-Lac, Québec
Two thumbs up!!! :wink:



_________________
PHOENIX GOLD
1.Reactor x3 #109, #407 & #496
2.Ti EQ30 x2
3.TiBasscube
4.TiDD10
5.TiPowercore 20
6.TLD66
7.Ti15 DVC x2
8.Ti5 Elite x4
9.Ti9 Elite
10.R-Link boxes x6 w/digital guages x12
11. Ti Distribution blocks (Power x4 & Ground x1)
ALPINE
1.TME-M750a x5
2.TMX-R1000 x3
OTHERS
1. IPAD 2
2. 32" LED Screen
3. PS3
Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 10:48 am 
No, you're a towel.
User avatar

Joined: Fri Aug 01, 2008 8:26 am
Posts: 938
Location: Butthole of Ohio
I always wondered how well the clean sweep works. Seems to be a pretty neat device. I considered getting one when I had my cadillac. Never got around to doing anything with it tho.



_________________
We don't need no stinkin' bass boost!
Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 2:40 pm 
Sherlock Homey
User avatar

Joined: Sun Oct 19, 2008 10:03 pm
Posts: 2517
Location: WEST SIIIIDE!!
what are the clones crossed over at? and what are you running for mid bass, and crossover points?
1 more thing....... FUCKING KICKASS INSTALL! This is probably the coolest Clone installs I have seen, awesome dude, simply awesome :metal:



_________________
Phorum PI!
Square woofers are GAY!!
Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 3:44 pm 

Joined: Sun Apr 15, 2007 2:11 pm
Posts: 64
thanks everyone for your comments. I have to say I do like this phorum. If I had more confidence in the reliabilty there would of been 2 zpa 0.3's and 1 zpa 0.5. But if they go wrong on the uk it is not easy to get fixed. So JL hd's it is. As for x-over points. I have heard so much about using clones with big mid bass etc. The front speakers are dynaudio sys 360's. This is a 7" mid bass, 3" soft dome mid and tweet. The system is x over at 80hz with 18db slope. you start doing 24 db and the phase goes a bit funny between mid bass and sub. Yeah I can do 63hz and for a sound offs its better. But for every day rocking and rolling 80hz is fine.

Someone mentioned about mechanical noises. The only time these make noises is when magnet shavings are caught in the magnet/coil gap. Clean them up and there rocking.

Over the years these are the most talked about drivers but I have hardly seen any functioning in cars.

But anyone who heard the 4 inthe dually would of gone wow!!! Now I love jl and we put one of these in 1.8 cuft and also a 13w7 in there small sealed box. we had half a 4 channel / series amp on them and it stayed right with it.

No subsonic filters are on and I have not had the squealing noise yet!!!!

Bass is so dry i.e no colourations you get from conventional speakers... Natural... Anyway I have waffled enough... But even to this day with all the new skool dudes... They look in and go urrrrr or wow or shit what are they!!! Which is cool cos that was my era!!!!


Offline
 Profile  
 
 Post subject:
PostPosted: Thu Mar 26, 2009 7:34 pm 
Voltage Ohms
User avatar

Joined: Sat Nov 26, 1983 4:00 am
Posts: 14699
Location: Burnaby, BC
Your cyclone should be crossed over at ~50Hz 24dB/oct, as it can't play ANYTHING above 60Hz.

Drop your midbass crossover down as well. With proper sound deadening, the System 360 should have no trouble playing down to 60Hz. If you find you're lacking midbass, try switching the phase around on your mids (usually just doing the passenger side mid yields a huge improvement).


Offline
 Profile  
 
 Post subject:
PostPosted: Fri Mar 27, 2009 2:46 am 
User avatar

Joined: Wed Dec 20, 2006 11:23 am
Posts: 2870
Location: Somewhere in Between
Tom beat me to it. They recommend 60 Hz at 18dB/oct.

Sweet install. I'd love to hear that. The only time I heard a Clone was in an open sound room back in '95 ish.



_________________
"ZPA's will have the same sound essentially as you get from the MS, they just feature a bigger shinier set of balls."

Install:
http://phoenixphorum.com/viewtopic.php?f=10&t=16998
Offline
 Profile  
 
 Post subject:
PostPosted: Fri Mar 27, 2009 8:08 am 
Dirty Harry
User avatar

Joined: Sat Jan 26, 2008 11:53 pm
Posts: 5678
Location: Oregon Grown
I seen the dually........... :mrgreen:
That truck was pure thunder.......... The IASCA booth said it was fukin with readings..........from 100 yards away :shock: :shock: :shock: :shock: :shock: :shock: :shock: :shock:
I sat in there with the reps for like 10 mins and asked questions like a noob....



_________________
Those tender little burgers with them little, itty-bitty grilled onions that just explode in ya mouth like flavor crystals every time you bite into one.. just makes me want to burn this muthafuka down.... Come on, Pookie, let's burn this muthafuka down!!!
Offline
 Profile  
 
 Post subject:
PostPosted: Fri Mar 27, 2009 9:49 am 
User avatar

Joined: Wed Dec 20, 2006 11:23 am
Posts: 2870
Location: Somewhere in Between
FuzzyHoNutz wrote:
I sat in there with the reps for like 10 mins and asked questions like a noob....
Aren't you???? :scratch:



_________________
"ZPA's will have the same sound essentially as you get from the MS, they just feature a bigger shinier set of balls."

Install:
http://phoenixphorum.com/viewtopic.php?f=10&t=16998
Offline
 Profile  
 
 Post subject: 60hz and above
PostPosted: Sat Mar 28, 2009 4:02 pm 

Joined: Sun Apr 15, 2007 2:11 pm
Posts: 64
Well after playing these I can safely break the myth or reality that they can't play above 60hz. They do.. But they just don;t do it with the same distortion as conventional speakers. However they are doing just fine. I would defo err towards a 3 cu ft enclosure per driver as 2 cuft restricts it a bit at low end. the best thing is the speed of the the response. well all good and thenks for your comments


Offline
 Profile  
 
 Post subject:
PostPosted: Sat Mar 28, 2009 5:38 pm 
Dirty Harry
User avatar

Joined: Sat Jan 26, 2008 11:53 pm
Posts: 5678
Location: Oregon Grown
smgreen20 wrote:
FuzzyHoNutz wrote:
I sat in there with the reps for like 10 mins and asked questions like a noob....
Aren't you???? :scratch:


In 95' I was............... :lol: :lol: :lol: Shit, I was 15 at the time I saw that truck.......



_________________
Those tender little burgers with them little, itty-bitty grilled onions that just explode in ya mouth like flavor crystals every time you bite into one.. just makes me want to burn this muthafuka down.... Come on, Pookie, let's burn this muthafuka down!!!
Offline
 Profile  
 
 Post subject: lights
PostPosted: Sun Mar 29, 2009 2:33 pm 

Joined: Sun Apr 15, 2007 2:11 pm
Posts: 64
Well I managed to sort the lights out. Plexi on the cyclones is always a winner.... Spot the oopppss did not push the amp panel down...


Attachments:
DSC_1291 edited.JPG
DSC_1291 edited.JPG [ 186.58 KiB | Viewed 10880 times ]
DSC_1290 edited.JPG
DSC_1290 edited.JPG [ 185.63 KiB | Viewed 10880 times ]
Offline
 Profile  
 
 Post subject:
PostPosted: Sun Mar 29, 2009 3:22 pm 
Voltage Ohms
User avatar

Joined: Sat Nov 26, 1983 4:00 am
Posts: 14699
Location: Burnaby, BC
That must look crazy with those vanes moving!


Offline
 Profile  
 
 Post subject:
PostPosted: Sun Mar 29, 2009 5:27 pm 
Mr. Nice Guy
User avatar

Joined: Wed Dec 13, 2006 4:39 pm
Posts: 5750
I like the lights! Nice touch!


Offline
 Profile  
 
 Post subject:
PostPosted: Mon Mar 30, 2009 5:08 am 
Hair Metal
Hair Metal
User avatar

Joined: Thu Jul 19, 2007 12:43 pm
Posts: 1266
Nice! I had lots of ideas about doing a similar mounting with the cyclones. I always thought they looked like some kind of turbo exhaust



_________________
Greg Kitching
Offline
 Profile  
 
 Post subject:
PostPosted: Mon Mar 30, 2009 6:22 am 
Flærdy flærdy børk børk
User avatar

Joined: Sun Jul 01, 2007 9:58 am
Posts: 2384
Awesome!



_________________
Selling your Ti9 mids? PM me, please..

I also need a DD10...
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 4 [ 90 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: