It is currently Wed Sep 30, 2020 6:30 pm

All times are UTC - 8 hours




 Page 1 of 1 [ 3 posts ] 
Author Message
 Post subject: Amp Repair in USA?
PostPosted: Wed Feb 12, 2020 1:31 pm 

Joined: Thu Jan 23, 2020 9:07 am
Posts: 8
Does anyone know where I can get my ti500.4 repaired?

I got a used JL Audio Slash 300/4 to use temporarily. It just doesn't sound the same as my PG.


Offline
 Profile  
 
 Post subject: Re: Amp Repair in USA?
PostPosted: Fri Feb 14, 2020 1:40 pm 
Short Bus Driver
User avatar

Joined: Sat Dec 30, 2006 8:50 am
Posts: 4249
What is wrong with the Ti500.4?



_________________
Got "schooled" by member shawn k on May 10th, 2011...
No longer really "in tune" with the audio industry, and probably have not been for some time.
Hands down the forum's most ignorant member...
Don't even know what Ohm's law is...
Offline
 Profile  
 
 Post subject: Re: Amp Repair in USA?
PostPosted: Fri Feb 14, 2020 1:47 pm 

Joined: Thu Jan 23, 2020 9:07 am
Posts: 8
had a loud hum. I believe its something with the crossover board since switching the dial on the front from high pass to...forgot what its set at it went away. I also noticed the gain wasn't even on the fronts either.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 3 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: Bing [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron