It is currently Tue Nov 13, 2018 9:21 pm

All times are UTC - 8 hours




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: Repair help
PostPosted: Tue Sep 26, 2017 7:30 pm 

Joined: Tue Sep 26, 2017 7:40 am
Posts: 1
I have a phenox gold 660 old school.6 channel 1000watt ,it's burning the two left fuses, any advice anyone?


Offline
 Profile  
 
 Post subject: Re: Repair help
PostPosted: Mon Feb 12, 2018 10:00 pm 

Joined: Tue Nov 06, 2012 9:30 pm
Posts: 99
willing to bed the caps are gone. Send it in to zed he will fix it


Offline
 Profile  
 
 Post subject: Re: Repair help
PostPosted: Tue Feb 13, 2018 10:38 am 
the Floor Sweeping Hack with Golden Ears

Joined: Fri Dec 19, 2008 9:53 pm
Posts: 14383
I assume you mean that its doing this with no speakers hooked up? If you do have input/output connected disconnect them, replace the fuses and see if they still blow.



_________________
what else can I say I am a grumpy asshole most of the time.
Offline
 Profile  
 
 Post subject: Re: Repair help
PostPosted: Wed Feb 14, 2018 4:57 am 
Mad Scientist
User avatar

Joined: Sat Apr 19, 2008 11:57 pm
Posts: 1435
Location: Beaverton 48612
What is a 660? Do you mean the xs6600? I think I have one of those out in the shop, and I thought that all the fuses were in parallel. If it's only blowing some of the fuses, that's odd. I'll take a look at mine when I get out to the shop...

I'm thinking of the fuses aren't all in parallel then this is the amp that has a power supply for the sub channels and one for the other 4 channels. If that's the case, the power supplies may be fused separately. It could be that one power supply is blown. If there is a blown power supply then there is probably damage to the channels it powered. It's not a super expensive repair, but I completely rebuild the affected channels, they are very problem prone after they have been stressed.

Oh, and yes, the caps need swapped, but it's not likely that is causing it to blow fuses...

Good luck,
Jason



_________________
M: M100, M44 for a custom amp project
Zx: Zx500, Zx450, Black Zx350
ZxTi: 4 Zx600Ti's, 1 Zx400Ti
Ti: 5 800.1's & 900.7 for a custom amp project. 1 1200.1, 1 1000.2
Tantrum: 2 1200.1's, 1 600.4, 1 500.2
XS: XS6600
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: