It is currently Fri Apr 03, 2020 1:47 am

All times are UTC - 8 hours




 Page 1 of 127 [ 6339 topics ]  Go to page 1, 2, 3, 4, 5 ... 127  Next
 

Car Audio

 Topics   Author   Replies   Views   Last post 
No unread posts Attachment(s) PG Rare & Limited Edition Registry

[ Go to page: 1 ... 16, 17, 18 ]

joerg

442

114966

Tue May 14, 2019 1:38 am

raippa View the latest post

No unread posts Attachment(s) Let's see your stash

[ Go to page: 1 ... 37, 38, 39 ]

stipud

971

222238

Fri Feb 09, 2018 6:10 am

opimax View the latest post

No unread posts Stolen Gear Registry

[ Go to page: 1, 2 ]

stipud

28

17454

Sat Jun 09, 2012 2:25 pm

dBincognito View the latest post

No unread posts Bridging ZX/Ti amps and RCA inputs

marko

5

36

Thu Apr 02, 2020 8:28 pm

marko View the latest post

No unread posts Attachment(s) ZPA 0.5 control board problem

[ Go to page: 1, 2 ]

Silverhorse

31

1945

Mon Mar 30, 2020 10:15 am

Silverhorse View the latest post

No unread posts Attachment(s) It's not just PG amps that have leaky cap issues...

vwdude

4

1514

Sat Mar 21, 2020 12:58 pm

Txsaxkat View the latest post

No unread posts Phoenix Gold Elite.2 distortion issue

MrTOOSHORT

3

584

Fri Mar 06, 2020 11:23 am

ladedruck View the latest post

No unread posts Attachment(s) Purple EQ232

lilviper

1

91

Thu Mar 05, 2020 8:06 pm

ttocs View the latest post

No unread posts Attachment(s) Bourns Pots for ti500.4

macky322

4

208

Thu Feb 20, 2020 5:56 pm

lilviper View the latest post

No unread posts PG XS2500 opinion?

macky322

2

129

Thu Feb 20, 2020 2:41 pm

Jacampb2 View the latest post

No unread posts Amp Repair in USA?

macky322

2

159

Fri Feb 14, 2020 1:47 pm

macky322 View the latest post

No unread posts Four XS104's

smgreen20

3

389

Tue Feb 11, 2020 6:15 pm

smgreen20 View the latest post

No unread posts Remote for old school Phoenix Gold Bass Cube

cjeffers84

12

759

Sun Feb 09, 2020 10:28 am

ttocs View the latest post

No unread posts ZX475ti hum with car off

macky322

6

292

Thu Jan 30, 2020 4:12 pm

Jacampb2 View the latest post

No unread posts Attachment(s) m25 amplifier not working

metterklus

12

495

Sat Jan 25, 2020 9:27 am

Silverhorse View the latest post

No unread posts Ms-275 cap question

kalvin90

2

205

Wed Jan 08, 2020 8:59 am

Silverhorse View the latest post

No unread posts Xvr 12

Oldskoolrules

1

154

Sun Jan 05, 2020 6:41 pm

ttocs View the latest post

No unread posts Zx350 caps & decals

demosta

1

209

Sat Jan 04, 2020 6:18 am

Eric D View the latest post

No unread posts Attachment(s) My new Tarantula

[ Go to page: 1, 2, 3, 4, 5 ]

Jacampb2

102

30484

Tue Nov 19, 2019 4:55 pm

Jacampb2 View the latest post

No unread posts Decals phoenix gold...

luigi66

4

587

Sun Nov 03, 2019 9:15 am

Silverhorse View the latest post

No unread posts anyone ever built a dual opposing woofer box?

ttocs

8

766

Thu Oct 24, 2019 5:48 am

JK View the latest post

No unread posts AX406a Question

kg1961

16

2016

Fri Oct 11, 2019 3:09 pm

ttocs View the latest post

No unread posts Help diagnosing zx475ti problem

mr2mike

9

856

Thu Oct 03, 2019 11:27 am

ttocs View the latest post

No unread posts New to me PG SX2 800.4.

smgreen20

0

283

Wed Sep 18, 2019 1:01 am

smgreen20 View the latest post

No unread posts Looking for help with zx475ti repair/upgrade

ssmokeyy

5

517

Sun Sep 15, 2019 9:01 pm

ttocs View the latest post

No unread posts Attachment(s) Phoenix Gold Bass Cube

[ Go to page: 1, 2, 3 ]

Kirghiz

64

13750

Mon Sep 09, 2019 5:50 am

ttocs View the latest post

No unread posts Attachment(s) ZX500 going into overload

Silverhorse

21

1901

Mon Sep 02, 2019 9:59 am

Silverhorse View the latest post

No unread posts Zx600 ti

lilviper

14

1975

Wed Aug 28, 2019 8:17 am

Jacampb2 View the latest post

No unread posts Please consider helping Perry Babbin

Jacampb2

1

355

Mon Aug 26, 2019 12:32 pm

Eric D View the latest post

No unread posts Zx450 sensitivity pot

zztunnell

4

509

Fri Aug 23, 2019 5:48 pm

zztunnell View the latest post

No unread posts Attachment(s) Titanium 600.2 Help Needed

ALR

8

963

Tue Aug 20, 2019 4:12 pm

ALR View the latest post

No unread posts M25 Route 66 help

Watt22

1

432

Sat Aug 10, 2019 5:07 pm

Jacampb2 View the latest post

No unread posts Someone to repair PG EQ215 & 215x

Hairoldman

6

652

Tue Jul 30, 2019 7:54 pm

ttocs View the latest post

No unread posts Which capacitors to use for MS / MPS amplifiers

luigi66

0

418

Mon Jul 15, 2019 6:22 am

luigi66 View the latest post

No unread posts Enough power for SR6500 components?

KrisM

4

623

Sun Jul 07, 2019 10:56 am

KrisM View the latest post

No unread posts Attachment(s) What type of capacitor?

Anders

1

505

Mon Jul 01, 2019 5:58 am

ttocs View the latest post

No unread posts Attachment(s) Phoenix Gold M100 distorted sound.

Anders

11

1369

Sat Jun 29, 2019 1:11 am

Anders View the latest post

No unread posts Capacitor question

Silverhorse

4

678

Wed Jun 26, 2019 9:36 am

Silverhorse View the latest post

No unread posts Infrequent crackle/buzz

Fresh

14

1334

Sat Jun 22, 2019 10:17 pm

lilviper View the latest post

No unread posts rebuilding an OG ms1000 Nickel

[ Go to page: 1 ... 5, 6, 7 ]

ttocs

174

35192

Fri Jun 14, 2019 2:45 pm

kg1961 View the latest post

No unread posts OMG...OMG...OMG...!!!

mr tibbs

13

1702

Tue Jun 04, 2019 10:37 am

keith2728 View the latest post

No unread posts Bass cube, clipping and output

Rickymojr

2

519

Thu May 30, 2019 2:54 pm

Rickymojr View the latest post

No unread posts Need help SQish sub + amp

ahsmodean

6

799

Tue May 28, 2019 10:12 pm

lilviper View the latest post

No unread posts need some technical help with m100.

frankyboy

1

489

Wed May 22, 2019 2:13 am

Mr. Wild View the latest post

No unread posts M100 Schematic

wesleyb420

10

1259

Sun May 12, 2019 12:43 am

frankyboy View the latest post

No unread posts ported basics for dummies?

ttocs

7

1002

Thu Apr 25, 2019 4:35 am

ttocs View the latest post

No unread posts Attachment(s) factory MPS2500 + MS250 in one sink

Silverhorse

12

1423

Tue Apr 23, 2019 8:33 am

RayBuck View the latest post

No unread posts EQ215x Not Powering Up

wesleyb420

4

709

Mon Apr 15, 2019 12:59 pm

wesleyb420 View the latest post

No unread posts Shallow Subs?

jbob0124

0

485

Sun Apr 07, 2019 9:53 am

jbob0124 View the latest post

No unread posts Attempting repair on a burned SA3.0X

[ Go to page: 1, 2 ]

Jacampb2

27

6864

Fri Apr 05, 2019 3:13 am

Jacampb2 View the latest post

Display topics from previous:  Sort by  
 Page 1 of 127 [ 6339 topics ]  Go to page 1, 2, 3, 4, 5 ... 127  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: Bing [Bot] and 5 guests


New posts    No unread posts No new posts    Announce Announcement
New posts [ Popular ]    No unread posts [ Popular ] No new posts [ Popular ]    Sticky Sticky
New posts [ Locked ]    No unread posts [ Locked ] No new posts [ Locked ]    Moved topic Moved topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron